AWS Getting Started - Configuring SnapReplicate and High Availability (SNAP HA)
Configuring SnapReplicate™
Having prepared the environment on both AWS SoftNAS instances, we can now set up high availability. The first step towards high availability in SoftNAS is to establish replication. SnapReplicate™ makes this as simple as completing a quick wizard.
The source node must be able to connect via HTTPS to the target node (similar to how the browser user logs into StorageCenter using HTTPS). HTTPS is used to create the initial SnapReplicate configuration.
Next, several SSH sessions are established to ensure two-way communications between the nodes is possible. When connecting two Amazon EC2 nodes, it is best to use the internal instance IP addresses, as traffic is routed internally by default between instances in EC2.
If you have not yet done so, the Security Group on each instance should be configured with the internal IP addresses of the paired instance (the source instance should recognize traffic from the target instance, and the target instance should recognize traffic from the source) to ensure both HTTPS and SSH traffic between instances is recognized.
See AWS Getting Started - Network Configuration (Security Groups) to learn more.
Enter the username for the secondary instance (target) in the Remote admin user ID text box.
The username should be softnas.
Enter the password for the secondary instance (target) and verify in the appropriate text boxes.
Unless changed, by default, the password will be the Instance ID of the target instance.
Configuring SNAP HA™
SnapReplicate™ establishes a replication relationship, one that can be manually triggered or scheduled, but is not automated. For true high availability in a failover situation, SNAP HA™ must be configured as well.
Configuration of SnapReplicate™ is a prerequisite to setup of SNAP HA™. If SnapReplicate™ is not configured, the Add SNAP HA™ button will be grayed out.
If you have not yet configured a notification email, you will need to provide one prior to continuing SNAP HA™.
The Virtual IP is a human-configured IP address (you choose the IP). It can be any IP address that falls outside the CIDR block of the IP addresses of the two SoftNAS HA paired nodes.
Provide your AWS Access Key and AWS Secret Key in the appropriate text boxes.
In most cases, your IAM Policy will handle this and you will not need to enter anything.
In the HA Num of retries text box, enter the max number of retries before your virtual machine fails over.
In the Storage timeout text box, enter the max time (in seconds) that storage can be unavailable before a failover is triggered.
In the Max. hoping request time (ms) text box, enter the default time for max ioping requests, to ensure that a failover is triggered more quickly in event of failure.
From the HA node recovery mode section, select the behavior of the failed node during a failover.
Reboot - this is the default option, allowing for quicker recovery and re-establishment of high availability, as the failed node will reboot, and SNAP HA will be reactivated, with the original node set as secondary.
Shutdown - The failed node will remain shut down. You will need to reboot the instance manually to re-establish high availability.
None (No action taken) - This option is only for debug or support use. The failed node will remain in its current state.